CVE-2014-3467 Affecting libtasn1-debuginfo package, versions <0:2.3-6.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
6.8% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBTASN1DEBUGINFO-1674733
  • published27 Sept 2021
  • disclosed5 Jun 2014

Introduced: 5 Jun 2014

CVE-2014-3467  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libtasn1-debuginfo to version 0:2.3-6.6.amzn1 or higher.
This issue was patched in ALAS-2014-359.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libtasn1-debuginfo package and not the libtasn1-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Multiple unspecified vulnerabilities in the DER decoder in GNU Libtasn1 before 3.6, as used in GnuTLS, allow remote attackers to cause a denial of service (out-of-bounds read) via crafted ASN.1 data.

CVSS Base Scores

version 3.1