Out-of-Bounds Affecting libvorbis-devel package, versions <1:1.2.3-4.6.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
7.84% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBVORBISDEVEL-1663624
  • published27 Sept 2021
  • disclosed1 Feb 2012

Introduced: 1 Feb 2012

CVE-2012-0444  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libvorbis-devel to version 1:1.2.3-4.6.amzn1 or higher.
This issue was patched in ALAS-2012-47.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libvorbis-devel package and not the libvorbis-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Mozilla Firefox before 3.6.26 and 4.x through 9.0, Thunderbird before 3.1.18 and 5.0 through 9.0, and SeaMonkey before 2.7 do not properly initialize nsChildView data structures, which allows remote attackers to cause a denial of service (memory corruption and application crash) or possibly execute arbitrary code via a crafted Ogg Vorbis file.

CVSS Base Scores

version 3.1