Integer Overflow or Wraparound Affecting libX11-common package, versions <0:1.6.0-2.2.13.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.58% (43rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBX11COMMON-1725223
  • published27 Sept 2021
  • disclosed11 Sept 2020

Introduced: 11 Sep 2020

CVE-2020-14363  (opens in a new tab)
CWE-190  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libX11-common to version 0:1.6.0-2.2.13.amzn1 or higher.
This issue was patched in ALAS-2021-1462.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libX11-common package and not the libX11-common package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

An integer overflow vulnerability leading to a double-free was found in libX11. This flaw allows a local privileged attacker to cause an application compiled with libX11 to crash, or in some cases, result in arbitrary code execution. The highest threat from this flaw is to confidentiality, integrity as well as system availability.

CVSS Base Scores

version 3.1