Out-of-Bounds Affecting libXi-debuginfo package, versions <0:1.7.2-2.2.9.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.33% (82nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBXIDEBUGINFO-1680308
  • published27 Sept 2021
  • disclosed15 Jun 2013

Introduced: 15 Jun 2013

CVE-2013-1999  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libXi-debuginfo to version 0:1.7.2-2.2.9.amzn1 or higher.
This issue was patched in ALAS-2014-452.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libXi-debuginfo package and not the libXi-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Buffer overflow in X.org libXvMC 1.0.7 and earlier allows X servers to cause a denial of service (crash) and possibly execute arbitrary code via crafted length or index values to the XvMCGetDRInfo function.

CVSS Base Scores

version 3.1