Heap-based Buffer Overflow Affecting libXpm-devel package, versions <0:3.5.10-2.12.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.48% (39th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBXPMDEVEL-6045917
  • published4 Nov 2023
  • disclosed10 Oct 2023

Introduced: 10 Oct 2023

CVE-2023-43787  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libXpm-devel to version 0:3.5.10-2.12.amzn1 or higher.
This issue was patched in ALAS-2023-1875.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libXpm-devel package and not the libXpm-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

A vulnerability was found in libX11 due to an integer overflow within the XCreateImage() function. This flaw allows a local user to trigger an integer overflow and execute arbitrary code with elevated privileges.

CVSS Base Scores

version 3.1