Improper Input Validation Affecting libxslt package, versions <0:1.1.26-2.7.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.22% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LIBXSLT-1665444
  • published27 Sept 2021
  • disclosed27 Jun 2012

Introduced: 27 Jun 2012

CVE-2012-2825  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 libxslt to version 0:1.1.26-2.7.amzn1 or higher.
This issue was patched in ALAS-2012-123.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libxslt package and not the libxslt package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The XSL implementation in Google Chrome before 20.0.1132.43 allows remote attackers to cause a denial of service (incorrect read operation) via unspecified vectors.

CVSS Base Scores

version 3.1