Out-of-Bounds Affecting lua-debuginfo package, versions <0:5.1.4-4.1.9.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
12.03% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-LUADEBUGINFO-1677188
  • published27 Sept 2021
  • disclosed4 Sept 2014

Introduced: 4 Sep 2014

CVE-2014-5461  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 lua-debuginfo to version 0:5.1.4-4.1.9.amzn1 or higher.
This issue was patched in ALAS-2014-402.

NVD Description

Note: Versions mentioned in the description apply only to the upstream lua-debuginfo package and not the lua-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Buffer overflow in the vararg functions in ldo.c in Lua 5.1 through 5.2.x before 5.2.3 allows context-dependent attackers to cause a denial of service (crash) via a small number of arguments to a function with a large number of fixed arguments.

CVSS Base Scores

version 3.1