Directory Traversal Affecting mailman-debuginfo package, versions <3:2.1.15-21.20.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
7.91% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-MAILMANDEBUGINFO-1689106
  • published27 Sept 2021
  • disclosed13 Apr 2015

Introduced: 13 Apr 2015

CVE-2015-2775  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 mailman-debuginfo to version 3:2.1.15-21.20.amzn1 or higher.
This issue was patched in ALAS-2015-582.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mailman-debuginfo package and not the mailman-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Directory traversal vulnerability in GNU Mailman before 2.1.20, when not using a static alias, allows remote attackers to execute arbitrary files via a .. (dot dot) in a list name.

CVSS Base Scores

version 3.1