Out-of-bounds Write Affecting mod24_fcgid package, versions <0:2.3.9-1.7.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
13.6% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-MOD24FCGID-1670545
  • published27 Sept 2021
  • disclosed17 Oct 2013

Introduced: 17 Oct 2013

CVE-2013-4365  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 mod24_fcgid to version 0:2.3.9-1.7.amzn1 or higher.
This issue was patched in ALAS-2013-239.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mod24_fcgid package and not the mod24_fcgid package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Heap-based buffer overflow in the fcgid_header_bucket_read function in fcgid_bucket.c in the mod_fcgid module before 2.3.9 for the Apache HTTP Server allows remote attackers to have an unspecified impact via unknown vectors.

CVSS Base Scores

version 3.1