Arbitrary Command Injection Affecting nagios-common package, versions <0:3.5.1-2.10.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
4.71% (92nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-NAGIOSCOMMON-1707959
  • published27 Sept 2021
  • disclosed31 Mar 2017

Introduced: 31 Mar 2017

CVE-2014-5009  (opens in a new tab)
CWE-77  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 nagios-common to version 0:3.5.1-2.10.amzn1 or higher.
This issue was patched in ALAS-2017-899.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios-common package and not the nagios-common package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Snoopy allows remote attackers to execute arbitrary commands. NOTE: this vulnerability exists due to an incomplete fix for CVE-2014-5008.