OS Command Injection Affecting nagios-devel package, versions <0:3.5.1-2.10.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
8.99% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-NAGIOSDEVEL-1708149
  • published27 Sept 2021
  • disclosed30 Oct 2008

Introduced: 30 Oct 2008

CVE-2008-4796  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 nagios-devel to version 0:3.5.1-2.10.amzn1 or higher.
This issue was patched in ALAS-2017-899.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nagios-devel package and not the nagios-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The _httpsrequest function (Snoopy/Snoopy.class.php) in Snoopy 1.2.3 and earlier, as used in (1) ampache, (2) libphp-snoopy, (3) mahara, (4) mediamate, (5) opendb, (6) pixelpost, and possibly other products, allows remote attackers to execute arbitrary commands via shell metacharacters in https URLs.

CVSS Base Scores

version 3.1