Incorrect Authorization Affecting nvidia-dkms package, versions <2:418.197.02-2018.03.117.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.35% (27th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-NVIDIADKMS-1726475
  • published27 Sept 2021
  • disclosed21 Apr 2021

Introduced: 21 Apr 2021

CVE-2021-1076  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 nvidia-dkms to version 2:418.197.02-2018.03.117.amzn1 or higher.
This issue was patched in ALAS-2021-1495.

NVD Description

Note: Versions mentioned in the description apply only to the upstream nvidia-dkms package and not the nvidia-dkms package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

NVIDIA GPU Display Driver for Windows and Linux, all versions, contains a vulnerability in the kernel mode layer (nvlddmkm.sys or nvidia.ko) where improper access control may lead to denial of service, information disclosure, or data corruption.

CVSS Base Scores

version 3.1