CVE-2011-3380 Affecting openswan-doc package, versions <0:2.6.36-1.12.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.27% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-OPENSWANDOC-1660525
  • published27 Sept 2021
  • disclosed17 Nov 2011

Introduced: 17 Nov 2011

CVE-2011-3380  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 openswan-doc to version 0:2.6.36-1.12.amzn1 or higher.
This issue was patched in ALAS-2011-6.

NVD Description

Note: Versions mentioned in the description apply only to the upstream openswan-doc package and not the openswan-doc package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Openswan 2.6.29 through 2.6.35 allows remote attackers to cause a denial of service (NULL pointer dereference and pluto IKE daemon crash) via an ISAKMP message with an invalid KEY_LENGTH attribute, which is not properly handled by the error handling function.

CVSS Base Scores

version 3.1