Cryptographic Issues Affecting pam-debuginfo package, versions <0:1.1.8-9.29.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.48% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PAMDEBUGINFO-1674774
  • published27 Sept 2021
  • disclosed8 May 2014

Introduced: 8 May 2014

CVE-2013-7041  (opens in a new tab)
CWE-310  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 pam-debuginfo to version 0:1.1.8-9.29.amzn1 or higher.
This issue was patched in ALAS-2014-354.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-debuginfo package and not the pam-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The pam_userdb module for Pam uses a case-insensitive method to compare hashed passwords, which makes it easier for attackers to guess the password via a brute force attack.

CVSS Base Scores

version 3.1