Out-of-Bounds Affecting pam-devel package, versions <0:1.1.1-13.20.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.53% (41st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PAMDEVEL-1666810
  • published27 Sept 2021
  • disclosed22 Jul 2012

Introduced: 22 Jul 2012

CVE-2011-3149  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 pam-devel to version 0:1.1.1-13.20.amzn1 or higher.
This issue was patched in ALAS-2013-160.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-devel package and not the pam-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The _expand_arg function in the pam_env module (modules/pam_env/pam_env.c) in Linux-PAM (aka pam) before 1.1.5 does not properly handle when environment variable expansion can overflow, which allows local users to cause a denial of service (CPU consumption).

CVSS Base Scores

version 3.1