Directory Traversal Affecting pam-devel package, versions <0:1.1.8-9.29.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
4.11% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PAMDEVEL-1674812
  • published27 Sept 2021
  • disclosed10 Apr 2014

Introduced: 10 Apr 2014

CVE-2014-2583  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 pam-devel to version 0:1.1.8-9.29.amzn1 or higher.
This issue was patched in ALAS-2014-354.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pam-devel package and not the pam-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Multiple directory traversal vulnerabilities in pam_timestamp.c in the pam_timestamp module for Linux-PAM (aka pam) 1.1.8 allow local users to create arbitrary files or possibly bypass authentication via a .. (dot dot) in the (1) PAM_RUSER value to the get_ruser function or (2) PAM_TTY value to the check_tty function, which is used by the format_timestamp_name function.

CVSS Base Scores

version 3.1