Improper Input Validation Affecting patch package, versions <0:2.7.1-10.10.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
5.33% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PATCH-1713245
  • published27 Sept 2021
  • disclosed6 Apr 2018

Introduced: 6 Apr 2018

CVE-2018-1000156  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 patch to version 0:2.7.1-10.10.amzn1 or higher.
This issue was patched in ALAS-2018-1008.

NVD Description

Note: Versions mentioned in the description apply only to the upstream patch package and not the patch package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

GNU Patch version 2.7.6 contains an input validation vulnerability when processing patch files, specifically the EDITOR_PROGRAM invocation (using ed) can result in code execution. This attack appear to be exploitable via a patch file processed via the patch utility. This is similar to FreeBSD's CVE-2015-1418 however although they share a common ancestry the code bases have diverged over time.