OS Command Injection Affecting patch-debuginfo package, versions <0:2.7.1-12.14.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.68% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PATCHDEBUGINFO-1720860
  • published27 Sept 2021
  • disclosed16 Aug 2019

Introduced: 16 Aug 2019

CVE-2018-20969  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 patch-debuginfo to version 0:2.7.1-12.14.amzn1 or higher.
This issue was patched in ALAS-2019-1312.

NVD Description

Note: Versions mentioned in the description apply only to the upstream patch-debuginfo package and not the patch-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

do_ed_script in pch.c in GNU patch through 2.7.6 does not block strings beginning with a ! character. NOTE: this is the same commit as for CVE-2019-13638, but the ! syntax is specific to ed, and is unrelated to a shell metacharacter.