Link Following Affecting perl-Archive-Tar package, versions <0:1.92-3.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
7.31% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PERLARCHIVETAR-1720697
  • published27 Sept 2021
  • disclosed7 Jun 2018

Introduced: 7 Jun 2018

CVE-2018-12015  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 perl-Archive-Tar to version 0:1.92-3.6.amzn1 or higher.
This issue was patched in ALAS-2019-1287.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-Archive-Tar package and not the perl-Archive-Tar package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

In Perl through 5.26.2, the Archive::Tar module allows remote attackers to bypass a directory-traversal protection mechanism, and overwrite arbitrary files, via an archive file containing a symlink and a regular file with the same name.