Link Following Affecting perl-IPTables-Parse package, versions <0:1.5-2.3.amzn1


Severity

Recommended
low

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.43% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PERLIPTABLESPARSE-1692839
  • published27 Sept 2021
  • disclosed7 Jun 2017

Introduced: 7 Jun 2017

CVE-2015-8326  (opens in a new tab)
CWE-59  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 perl-IPTables-Parse to version 0:1.5-2.3.amzn1 or higher.
This issue was patched in ALAS-2015-627.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-IPTables-Parse package and not the perl-IPTables-Parse package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The IPTables-Parse module before 1.6 for Perl allows local users to write to arbitrary files owned by the current user.