Use of Externally-Controlled Format String Affecting perl-YAML-LibYAML-debuginfo package, versions <0:0.38-2.2.amzn1


Severity

Recommended
low

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.43% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PERLYAMLLIBYAMLDEBUGINFO-1664064
  • published27 Sept 2021
  • disclosed9 Sept 2012

Introduced: 9 Sep 2012

CVE-2012-1152  (opens in a new tab)
CWE-134  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 perl-YAML-LibYAML-debuginfo to version 0:0.38-2.2.amzn1 or higher.
This issue was patched in ALAS-2012-69.

NVD Description

Note: Versions mentioned in the description apply only to the upstream perl-YAML-LibYAML-debuginfo package and not the perl-YAML-LibYAML-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Multiple format string vulnerabilities in the error reporting functionality in the YAML::LibYAML (aka YAML-LibYAML and perl-YAML-LibYAML) module 0.38 for Perl allow remote attackers to cause a denial of service (process crash) via format string specifiers in a (1) YAML stream to the Load function, (2) YAML node to the load_node function, (3) YAML mapping to the load_mapping function, or (4) YAML sequence to the load_sequence function.

CVSS Base Scores

version 3.1