CVE-2022-26635 Affecting php71-pecl-memcached package, versions <0:3.2.0-1.4.amzn1


Severity

Recommended
0.0
critical
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
21.44% (98th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PHP71PECLMEMCACHED-3247460
  • published25 Jan 2023
  • disclosed5 Apr 2022

Introduced: 5 Apr 2022

CVE-2022-26635  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 php71-pecl-memcached to version 0:3.2.0-1.4.amzn1 or higher.
This issue was patched in ALAS-2023-1674.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php71-pecl-memcached package and not the php71-pecl-memcached package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

PHP-Memcached v2.2.0 and below contains an improper NULL termination which allows attackers to execute CLRF injection. Note: Third parties have disputed this as not affecting PHP-Memcached directly.

CVSS Base Scores

version 3.1