Code Affecting php-ZendFramework-extras package, versions <0:1.12.5-1.8.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.35% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PHPZENDFRAMEWORKEXTRAS-1676215
  • published27 Sept 2021
  • disclosed16 Nov 2014

Introduced: 16 Nov 2014

CVE-2014-2683  (opens in a new tab)
CWE-17  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 php-ZendFramework-extras to version 0:1.12.5-1.8.amzn1 or higher.
This issue was patched in ALAS-2014-377.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-ZendFramework-extras package and not the php-ZendFramework-extras package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Zend Framework 1 (ZF1) before 1.12.4, Zend Framework 2 before 2.1.6 and 2.2.x before 2.2.6, ZendOpenId, ZendRest, ZendService_AudioScrobbler, ZendService_Nirvanix, ZendService_SlideShare, ZendService_Technorati, and ZendService_WindowsAzure before 2.0.2, ZendService_Amazon before 2.0.3, and ZendService_Api before 1.0.0 allow remote attackers to cause a denial of service (CPU consumption) via (1) recursive or (2) circular references in an XML entity definition in an XML DOCTYPE declaration, aka an XML Entity Expansion (XEE) attack. NOTE: this issue exists because of an incomplete fix for CVE-2012-6532.

CVSS Base Scores

version 3.1