Improper Authentication Affecting php-ZendFramework-full package, versions <0:1.12.5-1.8.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.8% (85th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PHPZENDFRAMEWORKFULL-1676190
  • published27 Sept 2021
  • disclosed4 Sept 2014

Introduced: 4 Sep 2014

CVE-2014-2685  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 php-ZendFramework-full to version 0:1.12.5-1.8.amzn1 or higher.
This issue was patched in ALAS-2014-377.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-ZendFramework-full package and not the php-ZendFramework-full package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The GenericConsumer class in the Consumer component in ZendOpenId before 2.0.2 and the Zend_OpenId_Consumer class in Zend Framework 1 before 1.12.4 violate the OpenID 2.0 protocol by ensuring only that at least one field is signed, which allows remote attackers to bypass authentication by leveraging an assertion from an OpenID provider.

CVSS Base Scores

version 3.1