Information Exposure Affecting php-ZendFramework-Ldap package, versions <0:1.12.1-1.6.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.71% (75th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PHPZENDFRAMEWORKLDAP-1666417
  • published27 Sept 2021
  • disclosed2 May 2013

Introduced: 2 May 2013

CVE-2012-5657  (opens in a new tab)
CWE-200  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 php-ZendFramework-Ldap to version 0:1.12.1-1.6.amzn1 or higher.
This issue was patched in ALAS-2013-153.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-ZendFramework-Ldap package and not the php-ZendFramework-Ldap package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The (1) Zend_Feed_Rss and (2) Zend_Feed_Atom classes in Zend_Feed in Zend Framework 1.11.x before 1.11.15 and 1.12.x before 1.12.1 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack.

CVSS Base Scores

version 3.1