Improper Authentication Affecting php-ZendFramework-Soap package, versions <0:1.12.9-1.10.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.5% (83rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PHPZENDFRAMEWORKSOAP-1681195
  • published27 Sept 2021
  • disclosed22 Oct 2014

Introduced: 22 Oct 2014

CVE-2014-8088  (opens in a new tab)
CWE-287  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 php-ZendFramework-Soap to version 0:1.12.9-1.10.amzn1 or higher.
This issue was patched in ALAS-2014-460.

NVD Description

Note: Versions mentioned in the description apply only to the upstream php-ZendFramework-Soap package and not the php-ZendFramework-Soap package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The (1) Zend_Ldap class in Zend before 1.12.9 and (2) Zend\Ldap component in Zend 2.x before 2.2.8 and 2.3.x before 2.3.3 allows remote attackers to bypass authentication via a password starting with a null byte, which triggers an unauthenticated bind.

CVSS Base Scores

version 3.1