Directory Traversal Affecting pigz package, versions <0:2.3.3-1.6.amzn1


Severity

Recommended
low

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.03% (86th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PIGZ-1683666
  • published27 Sept 2021
  • disclosed21 Jan 2015

Introduced: 21 Jan 2015

CVE-2015-1191  (opens in a new tab)
CWE-22  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 pigz to version 0:2.3.3-1.6.amzn1 or higher.
This issue was patched in ALAS-2015-499.

NVD Description

Note: Versions mentioned in the description apply only to the upstream pigz package and not the pigz package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Multiple directory traversal vulnerabilities in pigz 2.3.1 allow remote attackers to write to arbitrary files via a (1) full pathname or (2) .. (dot dot) in an archive.

CVSS Base Scores

version 3.1