Memory Leak Affecting privoxy package, versions <0:3.0.23-2.17.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.36% (72nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PRIVOXY-5496835
  • published4 May 2023
  • disclosed23 Dec 2021

Introduced: 23 Dec 2021

CVE-2021-44540  (opens in a new tab)
CWE-401  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 privoxy to version 0:3.0.23-2.17.amzn1 or higher.
This issue was patched in ALAS-2023-1739.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

A vulnerability was found in Privoxy which was fixed in get_url_spec_param() by freeing memory of compiled pattern spec before bailing.

CVSS Base Scores

version 3.1