Out-of-bounds Read Affecting privoxy package, versions <0:3.0.23-2.17.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.95% (78th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PRIVOXY-5496870
  • published4 May 2023
  • disclosed9 Mar 2021

Introduced: 9 Mar 2021

CVE-2021-20275  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 privoxy to version 0:3.0.23-2.17.amzn1 or higher.
This issue was patched in ALAS-2023-1739.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy package and not the privoxy package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

A flaw was found in privoxy before 3.0.32. A invalid read of size two may occur in chunked_body_is_complete() leading to denial of service.

CVSS Base Scores

version 3.1