Improper Input Validation Affecting privoxy-debuginfo package, versions <0:3.0.23-2.7.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.87% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PRIVOXYDEBUGINFO-1694186
  • published27 Sept 2021
  • disclosed27 Jan 2016

Introduced: 27 Jan 2016

CVE-2016-1983  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 privoxy-debuginfo to version 0:3.0.23-2.7.amzn1 or higher.
This issue was patched in ALAS-2016-663.

NVD Description

Note: Versions mentioned in the description apply only to the upstream privoxy-debuginfo package and not the privoxy-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The client_host function in parsers.c in Privoxy before 3.0.24 allows remote attackers to cause a denial of service (invalid read and crash) via an empty HTTP Host header.