Deserialization of Untrusted Data Affecting puppet3-server package, versions <0:3.7.4-1.13.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.76% (87th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PUPPET3SERVER-1706888
  • published27 Sept 2021
  • disclosed5 Jul 2017

Introduced: 5 Jul 2017

CVE-2017-2295  (opens in a new tab)
CWE-502  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 puppet3-server to version 0:3.7.4-1.13.amzn1 or higher.
This issue was patched in ALAS-2017-849.

NVD Description

Note: Versions mentioned in the description apply only to the upstream puppet3-server package and not the puppet3-server package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Versions of Puppet prior to 4.10.1 will deserialize data off the wire (from the agent to the server, in this case) with a attacker-specified format. This could be used to force YAML deserialization in an unsafe manner, which would lead to remote code execution. This change constrains the format of data on the wire to PSON or safely decoded YAML.