OS Command Injection Affecting python26-pygments package, versions <0:1.4-4.12.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
6.72% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PYTHON26PYGMENTS-1693040
  • published27 Sept 2021
  • disclosed8 Jan 2016

Introduced: 8 Jan 2016

CVE-2015-8557  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 python26-pygments to version 0:1.4-4.12.amzn1 or higher.
This issue was patched in ALAS-2015-630.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python26-pygments package and not the python26-pygments package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The FontManager._get_nix_font_path function in formatters/img.py in Pygments 1.2.2 through 2.0.2 allows remote attackers to execute arbitrary commands via shell metacharacters in a font name.

CVSS Base Scores

version 3.1