Out-of-Bounds Affecting python27-crypto package, versions <0:2.6.1-1.14.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
9.58% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PYTHON27CRYPTO-1704964
  • published27 Sept 2021
  • disclosed15 Feb 2017

Introduced: 15 Feb 2017

CVE-2013-7459  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 python27-crypto to version 0:2.6.1-1.14.amzn1 or higher.
This issue was patched in ALAS-2017-801.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python27-crypto package and not the python27-crypto package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Heap-based buffer overflow in the ALGnew function in block_templace.c in Python Cryptography Toolkit (aka pycrypto) allows remote attackers to execute arbitrary code as demonstrated by a crafted iv parameter to cryptmsg.py.