Numeric Range Comparison Without Minimum Check Affecting python27-imaging package, versions <0:1.1.6-19.10.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.9% (79th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PYTHON27IMAGING-5789749
  • published20 Jul 2023
  • disclosed4 Nov 2016

Introduced: 4 Nov 2016

CVE-2016-9190  (opens in a new tab)
CWE-839  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 python27-imaging to version 0:1.1.6-19.10.amzn1 or higher.
This issue was patched in ALAS-2023-1787.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python27-imaging package and not the python27-imaging package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Pillow before 3.3.2 allows context-dependent attackers to execute arbitrary code by using the "crafted image file" approach, related to an "Insecure Sign Extension" issue affecting the ImagingNew in Storage.c component.