Improper Input Validation Affecting python27-rsa package, versions <0:3.3-2.7.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
7.05% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PYTHON27RSA-1693698
  • published27 Sept 2021
  • disclosed13 Jan 2016

Introduced: 13 Jan 2016

CVE-2016-1494  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 python27-rsa to version 0:3.3-2.7.amzn1 or higher.
This issue was patched in ALAS-2016-644.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python27-rsa package and not the python27-rsa package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The verify function in the RSA package for Python (Python-RSA) before 3.3 allows attackers to spoof signatures with a small public exponent via crafted signature padding, aka a BERserk attack.