Out-of-Bounds Affecting python-simplejson package, versions <0:3.5.3-1.7.amzn1


Severity

Recommended
low

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
7.85% (95th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-PYTHONSIMPLEJSON-1676051
  • published27 Sept 2021
  • disclosed24 Aug 2017

Introduced: 24 Aug 2017

CVE-2014-4616  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 python-simplejson to version 0:3.5.3-1.7.amzn1 or higher.
This issue was patched in ALAS-2014-374.

NVD Description

Note: Versions mentioned in the description apply only to the upstream python-simplejson package and not the python-simplejson package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Array index error in the scanstring function in the _json module in Python 2.7 through 3.5 and simplejson before 2.6.1 allows context-dependent attackers to read arbitrary process memory via a negative index value in the idx argument to the raw_decode function.

CVSS Base Scores

version 3.1