Out-of-bounds Read Affecting quagga package, versions <0:0.99.22.4-4.17.amzn1


Severity

Recommended
high

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
14.84% (97th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-QUAGGA-1710416
  • published27 Sept 2021
  • disclosed19 Feb 2018

Introduced: 19 Feb 2018

CVE-2018-5380  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 quagga to version 0:0.99.22.4-4.17.amzn1 or higher.
This issue was patched in ALAS-2018-957.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga package and not the quagga package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The Quagga BGP daemon (bgpd) prior to version 1.2.3 can overrun internal BGP code-to-string conversion tables used for debug by 1 pointer value, based on input.