Out-of-Bounds Affecting quagga-debuginfo package, versions <0:0.99.20.1-1.4.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.3% (68th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-QUAGGADEBUGINFO-1664015
  • published27 Sept 2021
  • disclosed5 Apr 2012

Introduced: 5 Apr 2012

CVE-2012-0250  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 quagga-debuginfo to version 0:0.99.20.1-1.4.amzn1 or higher.
This issue was patched in ALAS-2012-70.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga-debuginfo package and not the quagga-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Buffer overflow in the OSPFv2 implementation in ospfd in Quagga before 0.99.20.1 allows remote attackers to cause a denial of service (daemon crash) via a Link State Update (aka LS Update) packet containing a network-LSA link-state advertisement for which the data-structure length is smaller than the value in the Length header field.

CVSS Base Scores

version 3.1