CVE-2013-6051 Affecting quagga-debuginfo package, versions <0:0.99.21-6.12.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.25% (81st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-QUAGGADEBUGINFO-1671736
  • published27 Sept 2021
  • disclosed14 Dec 2013

Introduced: 14 Dec 2013

CVE-2013-6051  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 quagga-debuginfo to version 0:0.99.21-6.12.amzn1 or higher.
This issue was patched in ALAS-2014-279.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga-debuginfo package and not the quagga-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The bgp_attr_unknown function in bgp_attr.c in Quagga 0.99.21 does not properly initialize the total variable, which allows remote attackers to cause a denial of service (bgpd crash) via a crafted BGP update.

CVSS Base Scores

version 3.1