CVE-2012-1820 Affecting quagga-devel package, versions <0:0.99.20.1-1.5.amzn1


Severity

Recommended
0.0
low
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.04% (64th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-QUAGGADEVEL-1664490
  • published27 Sept 2021
  • disclosed13 Jun 2012

Introduced: 13 Jun 2012

CVE-2012-1820  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 quagga-devel to version 0:0.99.20.1-1.5.amzn1 or higher.
This issue was patched in ALAS-2012-90.

NVD Description

Note: Versions mentioned in the description apply only to the upstream quagga-devel package and not the quagga-devel package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The bgp_capability_orf function in bgpd in Quagga 0.99.20.1 and earlier allows remote attackers to cause a denial of service (assertion failure and daemon exit) by leveraging a BGP peering relationship and sending a malformed Outbound Route Filtering (ORF) capability TLV in an OPEN message.

CVSS Base Scores

version 3.1