Arbitrary Code Injection Affecting rpm-build package, versions <0:4.8.0-16.36.amzn1


Severity

Recommended
medium

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
5.92% (93rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RPMBUILD-1661559
  • published27 Sept 2021
  • disclosed24 Dec 2011

Introduced: 24 Dec 2011

CVE-2011-3378  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rpm-build to version 0:4.8.0-16.36.amzn1 or higher.
This issue was patched in ALAS-2011-14.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm-build package and not the rpm-build package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

RPM 4.4.x through 4.9.x, probably before 4.9.1.2, allows remote attackers to cause a denial of service (memory corruption) and possibly execute arbitrary code via an rpm package with crafted headers and offsets that are not properly handled when a package is queried or installed, related to (1) the regionSwab function, (2) the headerLoad function, and (3) multiple functions in rpmio/rpmpgp.c.

CVSS Base Scores

version 3.1