Improper Input Validation Affecting rpm-build package, versions <0:4.8.0-19.38.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
4.29% (91st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RPMBUILD-1664031
  • published27 Sept 2021
  • disclosed4 Jun 2012

Introduced: 4 Jun 2012

CVE-2012-0060  (opens in a new tab)
CWE-20  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rpm-build to version 0:4.8.0-19.38.amzn1 or higher.
This issue was patched in ALAS-2012-61.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm-build package and not the rpm-build package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

RPM before 4.9.1.3 does not properly validate region tags, which allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via an invalid region tag in a package header to the (1) headerLoad, (2) rpmReadSignature, or (3) headerVerify function.

CVSS Base Scores

version 3.1