Inefficient Regular Expression Complexity Affecting rubygem20-nokogiri-doc package, versions <0:1.6.1-1.22.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.52% (89th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RUBYGEM20NOKOGIRIDOC-2866076
  • published10 Jun 2022
  • disclosed11 Apr 2022

Introduced: 11 Apr 2022

CVE-2022-24836  (opens in a new tab)
CWE-1333  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rubygem20-nokogiri-doc to version 0:1.6.1-1.22.amzn1 or higher.
This issue was patched in ALAS-2022-1595.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rubygem20-nokogiri-doc package and not the rubygem20-nokogiri-doc package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri &lt; v1.13.4 contains an inefficient regular expression that is susceptible to excessive backtracking when attempting to detect encoding in HTML documents. Users are advised to upgrade to Nokogiri &gt;= 1.13.4. There are no known workarounds for this issue.

CVSS Base Scores

version 3.1