Improper Handling of Unexpected Data Type Affecting rubygem20-nokogiri-doc package, versions <0:1.6.1-1.23.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
3.23% (88th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RUBYGEM20NOKOGIRIDOC-3157605
  • published6 Dec 2022
  • disclosed20 May 2022

Introduced: 20 May 2022

CVE-2022-29181  (opens in a new tab)
CWE-241  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rubygem20-nokogiri-doc to version 0:1.6.1-1.23.amzn1 or higher.
This issue was patched in ALAS-2022-1648.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rubygem20-nokogiri-doc package and not the rubygem20-nokogiri-doc package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Nokogiri is an open source XML and HTML library for Ruby. Nokogiri prior to version 1.13.6 does not type-check all inputs into the XML and HTML4 SAX parsers, allowing specially crafted untrusted inputs to cause illegal memory access errors (segfault) or reads from unrelated memory. Version 1.13.6 contains a patch for this issue. As a workaround, ensure the untrusted input is a String by calling #to_s or equivalent.

CVSS Base Scores

version 3.1