OS Command Injection Affecting rubygem24-rake package, versions <0:12.0.0-1.49.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
1.36% (69th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RUBYGEM24RAKE-1722056
  • published27 Sept 2021
  • disclosed24 Feb 2020

Introduced: 24 Feb 2020

CVE-2020-8130  (opens in a new tab)
CWE-78  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rubygem24-rake to version 0:12.0.0-1.49.amzn1 or higher.
This issue was patched in ALAS-2020-1385.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rubygem24-rake package and not the rubygem24-rake package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

There is an OS command injection vulnerability in Ruby Rake < 12.3.3 in Rake::FileList when supplying a filename that begins with the pipe character |.

CVSS Base Scores

version 3.1