CVE-2012-2125 Affecting rubygems package, versions <0:1.8.11-3.1.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
2.47% (84th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-RUBYGEMS-1664363
  • published27 Sept 2021
  • disclosed1 Oct 2013

Introduced: 1 Oct 2013

CVE-2012-2125  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 rubygems to version 0:1.8.11-3.1.amzn1 or higher.
This issue was patched in ALAS-2012-79.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rubygems package and not the rubygems package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

RubyGems before 1.8.23 can redirect HTTPS connections to HTTP, which makes it easier for remote attackers to observe or modify a gem during installation via a man-in-the-middle attack.

CVSS Base Scores

version 3.1