Arbitrary Code Injection Affecting spamassassin package, versions <0:3.4.2-2.14.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
0.98% (61st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-SPAMASSASSIN-1715194
  • published27 Sept 2021
  • disclosed17 Sept 2018

Introduced: 17 Sep 2018

CVE-2018-11781  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 spamassassin to version 0:3.4.2-2.14.amzn1 or higher.
This issue was patched in ALAS-2018-1091.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spamassassin package and not the spamassassin package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Apache SpamAssassin 3.4.2 fixes a local user code injection in the meta rule syntax.