Arbitrary Code Injection Affecting spamassassin-debuginfo package, versions <0:3.4.2-2.14.amzn1


Severity

Recommended
0.0
high
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
10.82% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-SPAMASSASSINDEBUGINFO-1715538
  • published27 Sept 2021
  • disclosed17 Sept 2018

Introduced: 17 Sep 2018

CVE-2018-11780  (opens in a new tab)
CWE-94  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 spamassassin-debuginfo to version 0:3.4.2-2.14.amzn1 or higher.
This issue was patched in ALAS-2018-1091.

NVD Description

Note: Versions mentioned in the description apply only to the upstream spamassassin-debuginfo package and not the spamassassin-debuginfo package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

A potential Remote Code Execution bug exists with the PDFInfo plugin in Apache SpamAssassin before 3.4.2.