Improper Access Control Affecting subversion-javahl package, versions <0:1.9.4-2.54.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
6.81% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-SUBVERSIONJAVAHL-1698349
  • published27 Sept 2021
  • disclosed5 May 2016

Introduced: 5 May 2016

CVE-2016-2167  (opens in a new tab)
CWE-284  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 subversion-javahl to version 0:1.9.4-2.54.amzn1 or higher.
This issue was patched in ALAS-2016-709.

NVD Description

Note: Versions mentioned in the description apply only to the upstream subversion-javahl package and not the subversion-javahl package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

The canonicalize_username function in svnserve/cyrus_auth.c in Apache Subversion before 1.8.16 and 1.9.x before 1.9.4, when Cyrus SASL authentication is used, allows remote attackers to authenticate and bypass intended access restrictions via a realm string that is a prefix of an expected repository realm string.

CVSS Base Scores

version 3.1