Out-of-Bounds Affecting t1utils package, versions <0:1.39-1.3.amzn1


Severity

Recommended
0.0
medium
0
10

Based on Amazon Linux security rating.

Threat Intelligence

EPSS
6.86% (94th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-AMZN201803-T1UTILS-1687004
  • published27 Sept 2021
  • disclosed8 Jun 2015

Introduced: 8 Jun 2015

CVE-2015-3905  (opens in a new tab)
CWE-119  (opens in a new tab)

How to fix?

Upgrade Amazon-Linux:2018.03 t1utils to version 0:1.39-1.3.amzn1 or higher.
This issue was patched in ALAS-2015-554.

NVD Description

Note: Versions mentioned in the description apply only to the upstream t1utils package and not the t1utils package as distributed by Amazon-Linux. See How to fix? for Amazon-Linux:2018.03 relevant fixed versions and status.

Buffer overflow in the set_cs_start function in t1disasm.c in t1utils before 1.39 allows remote attackers to cause a denial of service (crash) and possibly execute arbitrary code via a crafted font file.

CVSS Base Scores

version 3.1